I spent most of the day installing Leopard Server on an old PPC Mac Mini. Not the best machine to deploy on by any stretch but certainly adequate for our technology team to take it for a test drive. As this is the fifth (or so) OS X Server I’ve set up I wasn’t expecting too much trouble, though I’ve never set one up before that was going to offer as wide a range of services as this particular system will need to. The others were mostly for either serving web pages or lab management/file serving grunts.

After botching the first few installs by spending too much time being cute with DNS, I did a clean reinstall. The server install now offers you a couple options, including a very basic (“idiot mode”) install with a super-simple System Preference application, and an advanced mode which uses the faithful old Server Admin and Workgroup Manager applications. On my first few attempts I opted for the basic configuration, and on the later install opted for the advanced mode. You can use the Server Admin and Workgroup Manager applications if you choose the basic configuration on install, but get a warning informing you that you may mess up some of the basic settings and will be unable to use the System Preference application later.

I started off configuring Mail, and encountered a few speed bumps but got it running fairly quickly. The second challenge was configuring and installing SquirrelMail, which is pre-installed but not configured. As I’ve installed SquirrelMail previously it was not much of a problem, either. What was more problematic was configuring SquirrelMail’s address book so that it will display users on the system via Open Directory. Though I used the same settings as I had on a previous 10.4 installation, I kept getting a “Error initializing LDAP server” message when trying to display the address book contents. For those who may encounter the same problem I did, the issue is that by default SquirrelMail (and from what I read the default PHP LDAP configuration) defaults to LDAP v2. OS X Server 10.4 uses v3 by default, but had an option to allow use of v2. No such option in Leopard Server. A half hour of scouring the net turned up the answer – you must add the protocol line as seen below in the SquirrelMail config file:

$ldap_server[0] = Array(
    'host' => 'memberdir.netscape.com',
    'name' => 'Netcenter Member Directory',
    'base' => 'ou=member_directory,o=netcenter.com',
    'protocol' => 3
    );

After getting Mail set up, file serving, chat server, web server, blogs, wiki and DNS came online very quickly and smoothly. All of the web-based services handle UTF-8 beautifully, as do mail services. The whole process took about four hours. The way the blogs, wiki and email are tied into the users and groups in Open Directory is pretty darn slick.

Overall the experience was relatively painless considering I have yet to download any of the documentation ;-). More progress reports will be forethcoming as progress is made.

Related Posts

4 thoughts on “Leopard Server, Day 1

  1. Hi

    I would be really interested in directions on how you integrated the addressbook to the servers open directory.

    Thanks

Leave a Reply to mBrookes Cancel reply

Your email address will not be published. Required fields are marked *